www.quadsoftware.com
FAQ  FAQ   Search  Search   Memberlist  Memberlist   Usergroups  Usergroups
Register  ::  Log in Log in to check your private messages


Post new topic  Reply to topic Goto page 1, 2  Next
 One area missing on my project « View previous topic :: View next topic » 
Author Message
Finstern
PostPosted: Tue Feb 07, 2012 8:01 pm    Post subject: One area missing on my project Reply with quote



Joined: 09 Mar 2010
Posts: 24

I got the surprise to miss one of my zone, leaving a square hole in the terrain, the screen should be excplicit.



Here are the script logs,


Code:
[CALL] RunScript(Scripts/shutdown.as)    Error opening the file.
[AUTHENTICATOR] getting ID (first call)
[AUTHENTICATOR] getting ID (secondary call)
[AUTHENTICATOR] getting ID (secondary call)
[AUTHENTICATOR] getting ID (secondary call)
[AUTHENTICATOR] getting ID (secondary call)
[AUTHENTICATOR] getting ID (secondary call)
[AUTHENTICATOR] getting ID (secondary call)
[AUTHENTICATOR] getting ID (secondary call)
[AUTHENTICATOR] getting ID (secondary call)
[AUTHENTICATOR] getting ID (secondary call)
[AUTHENTICATOR] getting ID (secondary call)
Cannot load plug-in "ColladaStorage.plug": plugin not for this platform, skipping.
Warning parsing component "ColladaStorage.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "CropGeoTIFF.plug": plugin not for this platform, skipping.
Warning parsing component "CropGeoTIFF.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpCollada.plug": plugin not for this platform, skipping.
Warning parsing component "ExpCollada.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpGeneral.plug": plugin not for this platform, skipping.
Warning parsing component "ExpGeneral.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpGeoData.plug": plugin not for this platform, skipping.
Warning parsing component "ExpGeoData.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpGraphiTE.plug": plugin not for this platform, skipping.
Warning parsing component "ExpGraphiTE.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpRoadNetworks.plug": plugin not for this platform, skipping.
Warning parsing component "ExpRoadNetworks.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpTexture.plug": plugin not for this platform, skipping.
Warning parsing component "ExpTexture.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpTxt.plug": plugin not for this platform, skipping.
Warning parsing component "ExpTxt.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpBT.plug": plugin not for this platform, skipping.
Warning parsing component "ImpBT.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpGeoData.plug": plugin not for this platform, skipping.
Warning parsing component "ImpGeoData.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpGeoTIFF.plug": plugin not for this platform, skipping.
Warning parsing component "ImpGeoTIFF.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpKML.plug": plugin not for this platform, skipping.
Warning parsing component "ImpKML.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpRAW.plug": plugin not for this platform, skipping.
Warning parsing component "ImpRAW.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpRoadNetworks.plug": plugin not for this platform, skipping.
Warning parsing component "ImpRoadNetworks.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilCustomProp.plug": plugin not for this platform, skipping.
Warning parsing component "UtilCustomProp.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilShapeProc.plug": plugin not for this platform, skipping.
Warning parsing component "UtilShapeProc.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilSpawnInst.plug": plugin not for this platform, skipping.
Warning parsing component "UtilSpawnInst.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilStats.plug": plugin not for this platform, skipping.
Warning parsing component "UtilStats.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ColladaStorage.plug": plugin not for this platform, skipping.
Warning parsing component "ColladaStorage.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "CropGeoTIFF.plug": plugin not for this platform, skipping.
Warning parsing component "CropGeoTIFF.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpCollada.plug": plugin not for this platform, skipping.
Warning parsing component "ExpCollada.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpGeneral.plug": plugin not for this platform, skipping.
Warning parsing component "ExpGeneral.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpGeoData.plug": plugin not for this platform, skipping.
Warning parsing component "ExpGeoData.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpGraphiTE.plug": plugin not for this platform, skipping.
Warning parsing component "ExpGraphiTE.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpRoadNetworks.plug": plugin not for this platform, skipping.
Warning parsing component "ExpRoadNetworks.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpTexture.plug": plugin not for this platform, skipping.
Warning parsing component "ExpTexture.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpTxt.plug": plugin not for this platform, skipping.
Warning parsing component "ExpTxt.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpBT.plug": plugin not for this platform, skipping.
Warning parsing component "ImpBT.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpGeoData.plug": plugin not for this platform, skipping.
Warning parsing component "ImpGeoData.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpGeoTIFF.plug": plugin not for this platform, skipping.
Warning parsing component "ImpGeoTIFF.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpKML.plug": plugin not for this platform, skipping.
Warning parsing component "ImpKML.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpRAW.plug": plugin not for this platform, skipping.
Warning parsing component "ImpRAW.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpRoadNetworks.plug": plugin not for this platform, skipping.
Warning parsing component "ImpRoadNetworks.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilCustomProp.plug": plugin not for this platform, skipping.
Warning parsing component "UtilCustomProp.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilShapeProc.plug": plugin not for this platform, skipping.
Warning parsing component "UtilShapeProc.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilSpawnInst.plug": plugin not for this platform, skipping.
Warning parsing component "UtilSpawnInst.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilStats.plug": plugin not for this platform, skipping.
Warning parsing component "UtilStats.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ColladaStorage.plug": plugin not for this platform, skipping.
Warning parsing component "ColladaStorage.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "CropGeoTIFF.plug": plugin not for this platform, skipping.
Warning parsing component "CropGeoTIFF.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpCollada.plug": plugin not for this platform, skipping.
Warning parsing component "ExpCollada.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpGeneral.plug": plugin not for this platform, skipping.
Warning parsing component "ExpGeneral.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpGeoData.plug": plugin not for this platform, skipping.
Warning parsing component "ExpGeoData.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpGraphiTE.plug": plugin not for this platform, skipping.
Warning parsing component "ExpGraphiTE.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpRoadNetworks.plug": plugin not for this platform, skipping.
Warning parsing component "ExpRoadNetworks.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpTexture.plug": plugin not for this platform, skipping.
Warning parsing component "ExpTexture.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ExpTxt.plug": plugin not for this platform, skipping.
Warning parsing component "ExpTxt.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpBT.plug": plugin not for this platform, skipping.
Warning parsing component "ImpBT.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpGeoData.plug": plugin not for this platform, skipping.
Warning parsing component "ImpGeoData.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpGeoTIFF.plug": plugin not for this platform, skipping.
Warning parsing component "ImpGeoTIFF.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpKML.plug": plugin not for this platform, skipping.
Warning parsing component "ImpKML.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpRAW.plug": plugin not for this platform, skipping.
Warning parsing component "ImpRAW.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "ImpRoadNetworks.plug": plugin not for this platform, skipping.
Warning parsing component "ImpRoadNetworks.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilCustomProp.plug": plugin not for this platform, skipping.
Warning parsing component "UtilCustomProp.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilShapeProc.plug": plugin not for this platform, skipping.
Warning parsing component "UtilShapeProc.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilSpawnInst.plug": plugin not for this platform, skipping.
Warning parsing component "UtilSpawnInst.plug" of "Plugins": invalid format (Skipping)
Cannot load plug-in "UtilStats.plug": plugin not for this platform, skipping.
Warning parsing component "UtilStats.plug" of "Plugins": invalid format (Skipping)
[ERROR] The GEOData Exporter couldn't find georeference data on the current workspace!

==================================================
Opening scene workspace: camp_reb
==================================================

Invalid file format: could not find the libraries block for terrain zone "TerrainZone (12)"
Error loading terrain data zone "TerrainZone (12)" from project "Terrain"


The collada messages should be from my experiment at importing objects found on google squetchup library (with poor success I admit, it was a mess), but here it's the terrain that is missing.

Can I have some help ?
I don't have a recent save of this work .. should be a relief if you have any solution to get it work like intended again.

Thank you in advance for your answer.

(I didn't posted in bug since I don't know if it's a bug or me doing an error)
Back to top
View user's profile Send private message
ALicu
PostPosted: Wed Feb 08, 2012 8:02 am    Post subject: Reply with quote



Joined: 12 Feb 2007
Posts: 1326

Hi,

One of the terrain files don't load. Can you send me your scene? (both .workspace file and the associated folder with the same name). You can send it via email (licu at quadsoftware.com) or, if it is too big (over 10 mb), drop me an email and I will send you a FTP account to upload it.

Kind Regards,
Adrian L.
Back to top
View user's profile Send private message
Finstern
PostPosted: Wed Feb 08, 2012 12:45 pm    Post subject: Reply with quote



Joined: 09 Mar 2010
Posts: 24

Thank you, I will look that tonight.
Back to top
View user's profile Send private message
Finstern
PostPosted: Wed Feb 08, 2012 7:37 pm    Post subject: Reply with quote



Joined: 09 Mar 2010
Posts: 24

Since the project is heavy, I contacted you by @mail Adrian, awaiting your answer .. I will upload the files this night or next one.

Thank you again for your support.
Back to top
View user's profile Send private message
ALicu
PostPosted: Wed Feb 08, 2012 9:19 pm    Post subject: Reply with quote



Joined: 12 Feb 2007
Posts: 1326

Yes, thank you. Received the email and I've sent you the FTP login. Let me know if you have any issues uploading the files. We will keep the data safe and delete it once we debug it.

Kind Regards,
Adrian L.
Back to top
View user's profile Send private message
Finstern
PostPosted: Wed Feb 08, 2012 9:21 pm    Post subject: Reply with quote



Joined: 09 Mar 2010
Posts: 24

That's not a problem, you can keep it if you want, it's for a "non commercial" project, if it's usefull to you you can use it.
Back to top
View user's profile Send private message
Finstern
PostPosted: Tue Feb 21, 2012 4:17 pm    Post subject: Reply with quote



Joined: 09 Mar 2010
Posts: 24

Any new on this missing area ?
I don't want to stress the team, I just wondered if there area any hope for me to have the project back or if I need to do it again from scratch.
Back to top
View user's profile Send private message
ALicu
PostPosted: Tue Feb 21, 2012 4:19 pm    Post subject: Reply with quote



Joined: 12 Feb 2007
Posts: 1326

Hi,

I've sent you an email right after I've received the map from you (it was probably caught in your spam filter).

Seems that the zone area data is already missing from the scene you've sent. Here is the original email:

"The scene data you've sent doesn't contain TerrainZone (12) file (the one that gave you the error). You can check this by looking into Valley_Alicu\Terrain folder. You will see that TerrainZone (12).tdata is missing. This name is the internal name. Probably in the UI you will see this as TerrainZone11.

Did you save the scene again after the error occurred? Let me know if you still have the scene with this file in it. I will need it to test why it didn't load."

Kind Regards,
Adrian L.
Back to top
View user's profile Send private message
Finstern
PostPosted: Tue Feb 21, 2012 6:45 pm    Post subject: Reply with quote



Joined: 09 Mar 2010
Posts: 24

Ok, I will send you the original project then.
Back to top
View user's profile Send private message
Finstern
PostPosted: Sun Feb 26, 2012 4:43 pm    Post subject: Reply with quote



Joined: 09 Mar 2010
Posts: 24

Project uploaded to ftp ALicu.

Thank you again for your help.. (and I never found your mail, not even in my spam box :s)
Back to top
View user's profile Send private message
ALicu
PostPosted: Sun Feb 26, 2012 4:55 pm    Post subject: Reply with quote



Joined: 12 Feb 2007
Posts: 1326

Hi,

Ok, thank you for the map. I will check it first thing tomorrow morning, when I am back at the office and let you know my findings (I will also post them on the forum, not only via emails).

Regards,
Adrian L.
Back to top
View user's profile Send private message
ALicu
PostPosted: Mon Feb 27, 2012 8:40 am    Post subject: Reply with quote



Joined: 12 Feb 2007
Posts: 1326

Hi,

I've received the map and indeed the terrain zone data is invalid. It seems that the writing stopped somewhere during saving the color layers (or immediately after). I cannot figure out from data what went wrong, I just know that somewhere the write stopped.

Can you remember what was done differently for that terrain zone? Was it in swap, did it had different layers or editing in any way compared with the other zones? Do you remember the last operation you've made before the save? Did you ran out of disk space at any time?

I am sorry but I cannot restore your data from that zone since most of it is missing (as you can see the TerrainZone (12).tdata file is much smaller than the other .tdata files).

But it would be great if we can figure out why this was happened as this may be a major issue. Fortunately no other clients reported this kind of files corruption so maybe was just an isolate incident. We will study the file more maybe we can figure out what happened. Any help is greatly appreciated.

Kind Regards,
Adrian L.
Back to top
View user's profile Send private message
ALicu
PostPosted: Mon Feb 27, 2012 9:01 am    Post subject: Reply with quote



Joined: 12 Feb 2007
Posts: 1326

Hi,

Did you remember if the program crashed during save at one time? If not (if the program saved without crash) you should have got a message (at least at the console) with some write errors.

Regards,
Adrian L.
Back to top
View user's profile Send private message
Finstern
PostPosted: Mon Feb 27, 2012 11:49 am    Post subject: Reply with quote



Joined: 09 Mar 2010
Posts: 24

Oww begin to be some time ago now .. let me see ..

I had no "crash" for a long time, errors, freezes of some sort, but not the program dying and disappearing without warning, so I didn't saw messages you speak about, maybe in the console (I don't look a lot at it I admit), you think there are logs for the console I can retrieve and send you ?

Edit : about what happened .. well I had plenty of space (some hundreds of Go left) and plenty of ram avaiable (I have 8 Go) ..
I can't remind if I swapped but I can tell that my work HDD are SSD disks, they are working fine, no errors as for now.

In fact, I was working on the project one day, saved, and when coming back it loaded like that.

The only thing that I can think should have caused problems is my trying at import of colada mesh found on google sketchup gallery with very few success.. I added mesh, deleted it, added again, in an attempt to get it working well in Grome project.
But none of my tests were done on the area 12 that is missing, the area where I tryed some integration are ok.

As for colors .. I don't remind having problems at all in this area, I did lot of tests on the entire project, going back after each bad try but in the end when getting something I liked, there were no troubles and I begun to work with grass and tree integration.

The missing area incident happened long after I finished with textures.

I thank you for confirmation that project is wrecked, at least I'm not waiting anymore with false hope, I will redo it from scratch then ..


Last edited by Finstern on Mon Feb 27, 2012 12:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
ALicu
PostPosted: Mon Feb 27, 2012 11:54 am    Post subject: Reply with quote



Joined: 12 Feb 2007
Posts: 1326

Hi,

The console will usually show up automatically when there is an error (unless you choose not to, from an option in the preferences dialog).

What is really strange is that if an error occurs when a zone is written other files (for example the project file) should also reflect this error. But it doesn't. We are still looking to see if something that goes wrong when writing the zone goes unnoticed.

Did you had a low disk space at some point during that period? This may explain the zone not being written completely (but again, this is not the last zone in the scene, so why did it happen only to this)?

Was this zone edited as any other zone from that scene? It is very strange that all the other zones are intact.

Kind Regards,
Adrian L.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic  Reply to topic Goto page 1, 2  Next Page 1 of 2

Jump to:  



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Based on a template by Dustin Baccetti
Powered by phpBB © 2001, 2005 phpBB Group